SysTutorials Forums QA GNOME 3 "Natural scrolling" mouse option does not work

In GNOME 3 “Settings” -> “Devices” -> “Mouse & Touchpad”, after setting “Natural scrolling” to On, the scrolling is still as the same before (non-natural).

How to fix this?

This is likely related to the X11 driver.

Remove the xorg-x11-drv-synaptics driver if it is installed. And install the xorg-x11-drv-libinput driver if it is not installed. (Different distros may have different names for the packages).

After installing the drivers, restart your Linux box or the X server, the natural scrolling should be okay.

And remember to set the settings for GNOME 3 by

gsettings set org.gnome.desktop.peripherals.mouse natural-scroll false
gsettings set org.gnome.desktop.peripherals.touchpad natural-scroll false

or

gsettings set org.gnome.desktop.peripherals.mouse natural-scroll true
gsettings set org.gnome.desktop.peripherals.touchpad natural-scroll true

(some times, the settings are “reversed” what you expected)

  • This reply was modified 4 months, 1 week ago by  Eric Z Ma.
Reply To: GNOME 3 "Natural scrolling" mouse option does not work
Your information:





<a href="" title="" rel="" target=""> <blockquote cite=""> <code> <pre> <em> <strong> <del datetime=""> <ul> <ol start=""> <li> <img src="" border="" alt="" height="" width="">

Please share if you like this post: